We recommend using the newest version of your preferred browser for the best experience. Nutcache supports the following browsers:

  • Chrome version 69 and later
  • Firefox version 63 and later
  • Safari version 12.1 or later
  • Microsoft Edge version 19 and later

Did this answer your question?